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504 Errors

The following message appears in the Automation UI to alert you:

The system encountered an error.

504 Gateway Time-out

Visual example in Automation

(Screenshot of the 504 popup)

Details

504 Gateway Timeout is a server-side error message that indicates a downstream server—while acting as a gateway or proxy—didn't receive a response from an upstream server in time to complete its request.

In the context of Automation's system architecture, the downstream, or requesting, server corresponds to the Automation UI pod and the upstream server is the Kubernetes API endpoint pod.

Potential causes

There are several reasons why a server-to-server request may not complete in time, including:

  • A firewall problem. The protection systems of some firewalls can block requests.
  • Server overload or slow communication speed. A server running on low resources can become overloaded and respond to requests more slowly.
  • Network connection issue. Your network may be experiencing temporary connection problems.
  • API request delay. The API may be waiting for a request to a submitting service (for example GitLab, Mongo, Vault, OIDC provider) which itself is experiencing slowness.

Solution

It can be difficult to identify the root cause of a 504 error. The following list provides some troubleshooting tasks you can try:

  • Verify if there were any recent changes or updates to your firewall rules.
  • Increase the Kubernetes Horizontal Pod Autoscaling (HPA) threshold for the maximum number of API pods to handle larger loads.
  • Test if the issue persists on a different browser or device.
  • Refresh the page.
  • Wait 10 minutes to allow the system to complete other tasks.

DataKitchen Automation Architecture

Note

Still not working? Contact DataKitchen Support. We can work through this together.