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File Not Found

A message similar to one of the following appears in an order run log to alert you:

No such file or directory.

FileNotFoundError

Visual example in Automation

(Screenshot of error log)

Details

During an order run, the system expects to access a particular resource but the file cannot be located.

This issue can appear as an INFO or ERROR entry in the order run log, depending on the severity and impact.

Potential causes

There are several reasons why a file cannot be found, including:

  • The resource was incorrectly named versus the reference in the recipe variation.
  • The actual file location is not aligned with the expected location.
  • The file was not uploaded.

Solution

Step1: Verify the error

  1. Navigate to the Order Run Logs dialog of the affected order run.
  2. Take note of the path and filename that display next to the alert message.
  3. Make adjustments to your container or recipe setup.

    Continue with Step 2 below for how to.

Step 2: Adjust the setup

Based on the file path from Step 1 above:

  1. Navigate to the correct location.

    For example, open the File Editor, the Node Editor, or the CLI.

  2. Upload or edit the file.

  3. Save your changes and rerun the order.

Order Run Logs

Note

Still not working? Contact DataKitchen Support. We can work through this together.